Back to overview
Resolved
Crypto Payment Top-Up Delays - Issue fixed
Aug 3, 2026 at 8:50am UTC
Affected services
Dashboard - Web
Resolved
Aug 3, 2026 at 8:50am UTC
The issue affecting cryptocurrency account top-ups has been resolved.
Some cryptocurrency payments were taking longer than usual to appear in account balances. RPC services were not affected.
We have now applied a fix, and payments should be reflected normally. If you continue to experience any delays, please create a ticket through our support portal so our team can investigate.
Affected services