Back to overview
Resolved
Global outage on Stable chain
Jul 23, 2026 at 11:49am UTC
Affected services
Geo-distributed load balancer
Resolved
Jul 23, 2026 at 1:45pm UTC
The issue has been resolved. The nodes on the Stable are now operating normally again.
Affected services
Created
Jul 23, 2026 at 11:49am UTC
We are observing degraded performance on the Stable network. The issue is currently being investigated and addressed on the Stable network side.
Affected services