Back to overview
Resolved

API Keys and Payments Display Issues

Jul 11, 2026 at 1:50am UTC
Affected services
Dashboard - Web

Resolved
Jul 11, 2026 at 8:10am UTC

The UI issue has been fully resolved, and all balance top-ups made during the incident have now been credited.

If you still face any issues, please reach out to support@drpc.org

Created
Jul 11, 2026 at 1:50am UTC

We are investigating an issue affecting the loading of API key lists and the display of payment information in the UI.