Back to overview
Resolved

Elevated Error Rates in US-East

Jul 3, 2026 at 3:35am UTC
Affected services
Geo-distributed load balancer

Resolved
Jul 3, 2026 at 3:35am UTC

We experienced elevated error rates in the US-East region due to an issue in an internal synchronization component between 00:00 UTC and 03:35 UTC on July 3, 2026. The issue has been mitigated, and all services are operating normally.