Back to overview
Degraded
Issues with displaying statistics in the dashboard
May 22, 2026 at 7:24am UTC
Affected services
Dashboard - Web
Resolved
May 22, 2026 at 7:32am UTC
The issue with statistics is resolved
Affected services
Created
May 22, 2026 at 7:24am UTC
We are currently experiencing issues with statistics being displayed in the dashboard.
Affected services