Back to overview
Degraded

Increased Latency Asia

Apr 19 at 02:04pm EEST
Affected services
ASIA-SOUTHEAST (Singapore) Gateway
ASIA-NORTHEAST (Japan, Tokyo) Gateway

Resolved
Apr 19 at 05:53pm EEST

The ASIA-SOUTHEAST and ASIA-NORTHEAST clusters have recovered—latency in the Asia region should now be back to normal.

Created
Apr 19 at 02:04pm EEST

We have temporarily removed Asian clusters from load balancing due to ongoing infrastructure issues. As a result, clients connecting from Asia may experience increased latency.

Our Engineering team is actively working with the hosting provider to resolve the issue and restore full regional availability. We will share updates as progress is made.