Back to overview
Downtime

Blast network outage

May 28 at 11:26am EEST
Affected services
Blast Mainnet

Resolved
May 28 at 02:37pm EEST

Restored Blast functionality completely

Updated
May 28 at 11:49am EEST

We restored basic support for Blast, however some features may not work. We're working on restoring full functionality.

Created
May 28 at 11:26am EEST

Unfortunately, all of our Blast providers missed hardfork update for Blast, so they resyncing nodes. We will do our best to restore access ASAP