Back to overview
Resolved

Robinhood Network Degradation

Sep 4, 2026 at 12:30pm UTC
Affected services
Geo-distributed load balancer

Resolved
Sep 4, 2026 at 2:50pm UTC

The Robinhood performance has been stabilised.

If you still face any issues, please reach out to the Support portal.

Created
Sep 4, 2026 at 12:30pm UTC

There is an ongoing degradation affecting the Robinhood network. Multiple upstream providers are impacted, which may result in intermittent errors or request failures.

The most significant impact was observed approximately between 12:30 and 13:15 UTC. The issue is still ongoing, but the impact is currently lower than during that period.

Our team is actively monitoring the situation and applying routing mitigations where possible. We have also reached out to the Robinhood team with our findings to confirm the incident cause and the current network state.

We will provide further updates as more information becomes available.