Back to overview
Resolved
Delayed Crypto Top-Up Processing
Aug 18, 2026 at 6:30am UTC
Affected services
Dashboard - Web
Resolved
Aug 18, 2026 at 10:35am UTC
The issue has been resolved.
If you still have any issues, please raise a ticket using the Support portal.
Affected services
Created
Aug 18, 2026 at 6:30am UTC
We have identified a delay in processing crypto top-ups. Confirmed payments may not immediately appear in your balance or payment history.
All affected payments will be credited automatically as processing catches up. ETA: 1–2 hours.
Affected services