Back to overview
Resolved

TLS Certificate Compatibility Issue

Aug 14, 2026 at 11:20am UTC
Affected services
Geo-distributed load balancer

Resolved
Aug 14, 2026 at 11:20am UTC

Between 11:20 and 12:12 UTC on August 14, 2026, a routine TLS certificate rotation on lb.drpc.live caused TLS handshake failures for a subset of clients.

Our endpoints remained available and continued serving traffic normally throughout the incident. However, affected clients were unable to complete the TLS handshake, so their requests did not reach our servers.

The new certificate chained to a certificate authority root that was added to major trust stores in August 2023. Clients using older CA trust stores did not recognize this root and therefore rejected the connection.

We reverted to the previous certificate, which restored connectivity for all affected clients.

The incident is resolved, and no action is required from customers.